Spørgsmål og svar

Tilbage
Hvilken software kan jeg ikke bruge?
Det er dessverre en del generel og specifik programvare som vi ikke må tillate på vores kunders webhotel, af hensyn til ressourcebrug, sikkerhed og tjenestestabilitet.

Webhotel er en tjeneste for nettsider, og er ikke designet for at håndtere andre typer tjenester.


Generel programvare

Principer

Her er nogle af principene som gælder for programvare som må og ikke må køre på webhotel.

  • OK: programvare som enten kortvarig udføres via PHP eller CGI på webhotellet, eller som understøtter webhotel-vedlikehold på login-serveren
  • Ikke OK: programvare som har lang køretid, der bruger for meget ressourcer i form af minde (RAM/swap), prosessor (CPU), intensiv diskbrug og/eller intensiv databasebrug
  • Ikke OK: programvare som udgør sikkerhedsrisiko, utsendelse af ikke-bestilt e-mail (spam), programvare egnet for at skade tredjepart, eller programvare, der er ulovlig

Om begrænsninger for ressourcer

PHP-indstillingene vores har standardgrænser som ikke skal overskrides, og programvare som overskrider begrænsningene må blive tvangsafsluttet og deaktiveret.

CGI-programvare skal følge de samme begrænsningene.

Selv om programvare ikke byder de konkrete begrænsningene, må den bruge for meget ressourcer, så webserveren bliver overbelastet. Da fungerer ikke dine websider, og ikke websidene for nogle andre på samme webserver heller. I sådanne tilfeller vil vi midlertidig deaktivere det webhotellet som bruger for meget ressourcer.

Andre begrænsninger

Web-tjenerne ligger bag en brannmur som hindrer programvare som ikke betjenes via web (HTTP).

Det er alligevel en del typer programvare som uanset ikke tillates, uafhængig af om den køres på en web-tjener eller login.domaeneshop.dk. Listen indeholder eksempler, og er ikke uttømmende:

  • Bakdører
  • Bittorrent-klienter eller -tjenere, eller andre liknende distribueringstjenester
  • Brannmur-omgåelse, eller forsøg på dette
  • Chat-/IRC-roboter og -proxyer
  • Filbehandlings-script i PHP eller CGI (uafhængig af sprog)
  • Fjernindlogning til Unix shell via web
  • Krypto-mining o.l.
  • Obfuskert/krypteret programvare som ikke maskinelt må verificeres som tryg/original
  • Portscannere
  • Proxyer (f.ex. til anonymisering)
  • Remote shell (fjernindlogning) via web
  • Rootkits
  • Spam-programvare
  • Spionprogramvare
  • Svindelprogramvare (f.ex. phishing)
  • Tjenestenektværktøj (DoS/DDoS)
  • Video-transkodere
  • Virus, trojanere, o.l.
  • Usikker programvare (har kendte sikkerhedshuld)
  • Ydelsestester for max kapasitet på vores tjenere/maskiner/linier

Specifikke programmer

Følgende programvare er specifikt ikke tillat. Det er heller ikke tillat med programvare, der er basert på disse, undtagen hvis alle sikkerhedshuld/problemer er dokumenteret og verificeret tettet.

  • Adminer - MySQL-admin-værktøj, bruges som bakdør af datakriminelle
  • BackWPup - Backup-plugin for WordPress med absurd ressourcebrug
  • CcMail fra Cicoandcico - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2005.
  • Chronoforms 4 og 5 - tillader automatisert spamming
  • CuteNews - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2008.
  • eXtplorer - Joomla-extension, fundamentalt usikker programvare
  • FCKeditor - Erstattet af CKEditor i 2010
  • FreeWebshop.org - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2008.
  • JetPack Sharing/Sharedaddy - modul til JetPack for WordPress, tillader spamming og JetPack-udbyderen forstår ikke problemet.
  • Joomla-versioner som ikke findes i sikker version og ikke vedlikeholdes, f.ex.:
    • 0.x
    • 1.0.x
    • 1.5.x
    • 1.6.x
    • 1.7.x
    • 2.5.x
    • 3.0.x
    • 3.1.x
    • 3.2.x
    • 3.3.x
    • 3.4.x
    • 3.5.x
    • 3.6.x
    • 3.7.x/li>
    • 3.8.1 og ældre
  • Lightbox Photo Gallery - WordPress-plugin, ingen sikker version eksisterer, blev trukket fra markedet pga. bakdører.
  • Lightbox Plus Colorbox - WordPress-plugin, ingen sikker version eksisterer, blev trukket fra markedet pga. bakdører.
  • Mambo - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2008.
  • Openads - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2008.
  • OpenX - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2012.
  • osCommerce - ingen sikker version, ekstremt dårlig sikkerhedshistorik
  • PHP-Fusion - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2013.
  • PHP-Nuge - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2007.
  • PostNuke - ingen sikker version eksisterer, offisielt afsluttet juli 2009.
  • Shortcode Excec PHP - WordPress-plugin, fundamentalt usikker programvare, prosjektet blev fjernet fra WordPress' websider i 2015.
  • ShoutPro - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2006.
  • sNews - ingen sikker version eksisterer, vedlikeholdes ikke og er ikke opdateret siden 2011.
  • TimThumb - WordPress-plugin, brugt til themes frem til 2009, ingen sikker version eksisterer, prosjektet blev nedlagt i 2014.

Undgå disse programmene

Vi ber om, at du ikke installerer følgende programvare på webhotel, da de ofte skaber problemer. Brugere som besøger eller administrerer websider med disse programmene risikerer at spærre sig selv ute pga. ekstrem ressourcebrug.

  • All-in-One WP Migration - WordPress-plugin for at migrere WordPress-sider, vi anbefaler Akeeba Backup
  • Backupbuddy - WordPress-plugin for at tage backup, vi anbefaler Akeeba Backup
  • Backup to Dropbox - WordPress-plugin for at tage backup til Dropbox, utløser en bug i WordPress som lager mange titalls millioner fejlmældinger på kort tid.
  • Better Search and Replace - WordPress-plugin, brug heller Akeeba Backup for flytning af WordPress mellom nettsteder
  • Cherry Plugin - WordPress-plugin
  • Cornerstone - WordPress-plugin
  • Craft CMS - kræver dedikert eller virtuel webserver
  • Imagify Image Optimizer - WordPress-plugin
  • JetPack for WordPress, fordi vanlig modul Sharing/Sharedaddy må bruges til spamming
  • Merge + Minify + Refresh for WordPress, fordi den skal starte Java for hver CSS/JS som skal "minimeres", noget som bruger uforholdsmæssig meget ressourcer.
  • Online Backup for Wordpress ("wponlinebackup") - backupløsning for WordPress, fjernet fra wordpress.org i 2015 eller tidligere, fuldstændig ubrugelig og lager ekstreme mængder fejlmældinger
  • Photo Gallery by Gallery Bank ("gallery-bank") - WordPress-plugin
  • Thrive Visual Editor - WordPress-plugin
  • Vaultpress - backupløsning for WordPress, designet for brug med websider hostet på wordpress.com og på dedikerte servere, uegnet for delte servere (webhotel)
  • Wordfence - sikkerhed for WordPress, går ofte løbsk og fylder enten disk eller database med mange gigabyte data

Se også:

Søgeord:  

Indholdsfortegnelse

© 2018 Domeneshop AS · Om os · Vilkår · Fortrolighedspolitik