Frågor och svar

Tillbaka
Vad för sorts programvara kan jag inte använda?
Det er dessverre en del generell og spesifikk programvare som vi ikke kan tillate på våre kunders webhotell, av hensyn til ressursbruk, sikkerhet og tjenestestabilitet.

Webhotell er en tjeneste for nettsider, og er ikke designet for å håndtere andre typer tjenester.


Generell programvare

Prinsipper

Her er noen av prinsippene som gjelder for programvare som kan og ikke kan kjøre på webhotell.

  • OK: programvare som enten kortvarig utføres via PHP eller CGI på webhotellet, eller som understøtter webhotell-vedlikehold på login-serveren
  • Ikke OK: programvare som har lang kjøretid, som bruker for mye ressurser i form av minne (RAM/swap), prosessor (CPU), intensiv diskbruk og/eller intensiv databasebruk
  • Ikke OK: programvare som utgjør sikkerhetsrisiko, utsendelse av ikke-bestilt epost (spam), programvare egnet for å skade tredjepart, eller programvare som er ulovlig

Om begrensninger for ressurser

PHP-innstillingene våre har standardgrenser som ikke skal overskrides, og programvare som overskrider begrensningene kan bli tvangsavsluttet og deaktivert.

CGI-programvare skal følge de samme begrensningene.

Selv om programvare ikke bryter de konkrete begrensningene, kan den bruke for mye ressurser, slik at webserveren blir overbelastet. Da fungerer ikke dine websider, og ikke websidene for noen andre på samme webserver heller. I slike tilfeller vil vi midlertidig deaktivere det webhotellet som bruker for mye ressurser.

Andre begrensninger

Web-tjenerne ligger bak en brannmur som hindrer programvare som ikke betjenes via web (HTTP).

Det er likevel en del typer programvare som uansett ikke tillates, uavhengig av om den kjøres på en web-tjener eller login.domeneshop.no. Listen inneholder eksempler, og er ikke uttømmende:

  • Bakdører
  • Bittorrent-klienter eller -tjenere, eller andre liknende distribueringstjenester
  • Brannmur-omgåelse, eller forsøk på dette
  • Chat-/IRC-roboter og -proxyer
  • Filbehandlings-script i PHP eller CGI (uavhengig av språk)
  • Fjerninnlogging til Unix shell via web
  • Krypto-mining o.l.
  • Obfuskert/kryptert programvare som ikke maskinelt kan verifiseres som trygg/original
  • Portscannere
  • Proxyer (f.eks. til anonymisering)
  • Remote shell (fjerninnlogging) via web
  • Rootkits
  • Spam-programvare
  • Spionprogramvare
  • Svindelprogramvare (f.eks. phishing)
  • Tjenestenektverktøy (DoS/DDoS)
  • Video-transkodere
  • Virus, trojanere, o.l.
  • Usikker programvare (har kjente sikkerhetshull)
  • Ytelsestester for maks kapasitet på våre tjenere/maskiner/linjer

Spesifikke programmer

Følgende programvare er spesifikt ikke tillatt. Det er heller ikke tillatt med programvare som er basert på disse, unntatt hvis alle sikkerhetshull/problemer er dokumentert og verifisert tettet.

  • Adminer - MySQL-admin-verktøy, brukes som bakdør av datakriminelle
  • BackWPup - Backup-plugin for WordPress med absurd ressursbruk
  • CcMail fra Cicoandcico - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2005.
  • Chronoforms 4 og 5 - tillater automatisert spamming
  • CuteNews - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2008.
  • eXtplorer - Joomla-extension, fundamentalt usikker programvare
  • FCKeditor - Erstattet av CKEditor i 2010
  • FreeWebshop.org - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2008.
  • JetPack Sharing/Sharedaddy - modul til JetPack for WordPress, tillater spamming og JetPack-leverandøren forstår ikke problemet.
  • Joomla-versjoner som ikke finnes i sikker versjon og ikke vedlikeholdes, f.eks.:
    • 0.x
    • 1.0.x
    • 1.5.x
    • 1.6.x
    • 1.7.x
    • 2.5.x
    • 3.0.x
    • 3.1.x
    • 3.2.x
    • 3.3.x
    • 3.4.x
    • 3.5.x
    • 3.6.x
    • 3.7.x/li>
    • 3.8.1 og eldre
  • Lightbox Photo Gallery - WordPress-plugin, ingen sikker versjon eksisterer, ble trukket fra markedet pga. bakdører.
  • Lightbox Plus Colorbox - WordPress-plugin, ingen sikker versjon eksisterer, ble trukket fra markedet pga. bakdører.
  • Mambo - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2008.
  • Openads - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2008.
  • OpenX - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2012.
  • osCommerce - ingen sikker versjon, ekstremt dårlig sikkerhetshistorikk
  • PHP-Fusion - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2013.
  • PHP-Nuke - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2007.
  • PostNuke - ingen sikker versjon eksisterer, offisielt avsluttet juli 2009.
  • Shortcode Excec PHP - WordPress-plugin, fundamentalt usikker programvare, prosjektet ble fjernet fra WordPress' websider i 2015.
  • ShoutPro - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2006.
  • sNews - ingen sikker versjon eksisterer, vedlikeholdes ikke og er ikke oppdatert siden 2011.
  • TimThumb - WordPress-plugin, brukt til themes fram til 2009, ingen sikker versjon eksisterer, prosjektet ble nedlagt i 2014.

Unngå disse programmene

Vi ber om at du ikke installerer følgende programvare på webhotell, da de ofte skaper problemer. Brukere som besøker eller administrerer websider med disse programmene risikerer å sperre seg selv ute pga. ekstrem ressursbruk.

  • All-in-One WP Migration - WordPress-plugin for å migrere WordPress-sider, vi anbefaler Akeeba Backup
  • Backupbuddy - WordPress-plugin for å ta backup, vi anbefaler Akeeba Backup
  • Backup to Dropbox - WordPress-plugin for å ta backup til Dropbox, utløser en bug i WordPress som lager mange titalls millioner feilmeldinger på kort tid.
  • Better Search and Replace - WordPress-plugin, bruk heller Akeeba Backup for flytting av WordPress mellom nettsteder
  • Cherry Plugin - WordPress-plugin
  • Cornerstone - WordPress-plugin
  • Craft CMS - krever dedikert eller virtuell webserver
  • Imagify Image Optimizer - WordPress-plugin
  • JetPack for WordPress, fordi vanlig modul Sharing/Sharedaddy kan brukes til spamming
  • Merge + Minify + Refresh for WordPress, fordi den må starte Java for hver CSS/JS som skal "minimeres", noe som bruker uforholdsmessig mye ressurser.
  • Online Backup for Wordpress ("wponlinebackup") - backupløsning for WordPress, fjernet fra wordpress.org i 2015 eller tidligere, fullstendig ubrukelig og lager ekstreme mengder feilmeldinger
  • Photo Gallery by Gallery Bank ("gallery-bank") - WordPress-plugin
  • Thrive Visual Editor - WordPress-plugin
  • Vaultpress - backupløsning for WordPress, designet for bruk med websider hostet på wordpress.com og på dedikerte servere, uegnet for delte servere (webhotell)
  • Wordfence - sikkerhet for WordPress, går ofte løpsk og fyller enten disk eller database med mange gigabyte data

Se även:

Sökord:  

Innehållsförteckning

© 2018 Domeneshop AS · Om oss · Villkor · Dataskydd